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Safety Precautions
Mechanical Hazards
The following mechanical precautions should always be observed, especially when
operating large, powerful components:
Crush-Collision Danger to Personnel— Even small mechanical components can exert
sufficient force to crush or injure you! Before powering your motion control system, verify
that personnel, including their hands, fingers and feet are clear of the movement zone. If
you have not already done so, define the movement zone, then employ barriers and/or
clearly marked boundary lines so that personnel are excluded from the zone. Before
powering motion control components, verify that all personnel remain outside the
movement zone.
Crush-Collision Hazard to Equipment— The same precautions applied to personnel
should be observed for equipment. Components can be damaged or destroyed due to
collision with other components or fixed hardware.
Component Hazards— Motion control may be applied to components which them-
selves present hazards. These include welders, saws, lasers, presses, cutters, etc. Be
aware that the introduction of movement to a component extends the reach and range
of that component’s hazards. In addition, any object can be made dangerous if suddenly
jarred loose or pitched due to sudden, wild movements. When testing new applications,
it is recommended that you begin at very low speeds, then slowly increase to the design
speed.

Electrical Hazards
Electrocution Hazard— Some motion control systems utilize high voltages and currents
which present hazards to personnel. During installation and servicing of components:
Power off all electrical components and accessories connected to your motion control
system.
Unplug electrical devices from their source of power. Safe-lock all power plugs to
prevent them from being plugged in during servicing.
Allow sufficient time for components using capacitors to discharge fully before making
connections.
Do not repower any components until installation is complete and personnel are clear of
component spaces.
ESD— Due to the use of sensitive microelectronics, all XMP boards are subject to
damage due to electrostatic discharge (ESD). When handling XMP components, users
are advised to observe basic ESD precautions, including the use of grounding straps
and grounding mats. Removed XMP components should always be stored in protective
ESD bags and/or cases.
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This guide is intended to be an introductory
manual covering MEI’s robust software and
tuning utilites.  For full documentation on all of
MEI’s products and capabilites please visit us
on the web at www.motioneng.com or email
info@motioneng.com.

Click the execute button and the program will now be
carried out.  You can stop the motion anytime by hitting any
key.

Open Motion Scope and here again you can view certain
parameters by selecting the Trace button and adding those
parameters you want to graph.�
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Change to File View  and select quickStart1 files.

Right click on the quickStart1 files and ‘Set as Active Project”:
this should set the quickStart1 files in bold.

Click on quickStart1.c in the ‘Source Files’ sub directory.

Go to the Build menu and select Build quickStart1.exe.

Make sure that there are no errors or warnings in the dialog
box.
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Overview
XMP PCI and the Motion Developer Kit (MDK)

This guide will take you through installing the Motion Developer

Kit (MDK) software and the XMP motion controller.  You will use

Motion Console to run a simple trapezoidal move with the test

stand motor and Motion Scope to gather information about the

associated motion.  This guide lets  you sample some of the

powerful tuning tools MEI offers to get you up and running fast.

This guide also shows how to execute a C-program using

Microsoft Visual C/C++ to introduce users to executing files

developed from C-code.  If you are not running MSVC v.4 or

higher, this portion of the guide will not apply.  However the

MDK supports C-code written on many platforms to perform

motion tasks.

25

Microsoft Visual C/C++
This section is an overview of running an
executable C-program via Microsoft Visual C/C++.
If you are not currently running MS Visual C/C++,
this section will not apply.  However, the XMP can
be controlled by a C-program written on many
different  platforms; this section covers MS Visual
C/C++ only.

Open Visual C/C++ Version 4 or higher.

Go to File -> Open Workspace.  Browse for app.mak. Usually
in    C-> MEI -> XMP ->
APP -> (OSDirectory)
-> MSVC.

The file type should be
set to display Makefile
[.mak] and upon doing
so the app.mak file
appears.  Open
app.mak and click Yes
to convert to the
version of visual C/
C++ you are running.

At this screen click OK, or press Enter if the button is off the
screen.
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Parts List
MEI supplied components to get you started.

XMP Series Controller

Connector Cable*

Single Axis MEI Test Stand*
(power cable included)

*  Available with the Motion Developer’s Kit.  Please
contact Motion Engineering for more information.

Motion Developers Kit CD*

24

When selecting a trace, by default it will turn white
indicating selection.  The selected trace will remain
white until you deselect or click anywhere on the
scope background.  You should notice the trace
selected for command position is now the color you
chose.  To return to the normal view click the ‘Zoom
Out’ button.

Go back to Motion Console and stop the motion by clicking on
the Stop button in the MS Summary window under the Actions
tab.

Zero the register by clicking the   button and clear any
faults by clicking the clear fault button  .  This will ready
the controller for carrying out the quickstart1.c program cov-
ered in the next section.
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Click and drag a selection
of the display like the one
shown.

Click the ‘Zoom In’ button

.  This will give a

finer resolution of the data.

To better distinguish between
separate traces, select Ax 0 Cmd
Pos from the trace field (you can
also select the trace by right
clicking on the trace directly) and
select Trace -> Color from the menu.   You are now pre-
sented with a color palette to choose a variety of preset
colors along with the option to customize colors to assign to
any trace.

Choose a color and click OK.

Installing the XMP Controller

The XMP/PCI controller fits into a full-sized PCI
slot in your computer.  Because PC configurations
vary, we recommend you refer to the expansion
card installation instructions that came with your
computer.  If you do not feel comfortable
performing the hardware installation, consult a
qualified technician.  Please refer to the Safety
Precautions located at the beginning of this
manual.

•  MEI assumes no liability for any damage caused either
directly or indirectly  by improper installation of compo-
nents.

•  Make sure power is
OFF during the installa-
tion.

Shut down your computer
and follow the manufactur-
ers instruction for opening
the computer and install-
ing hardware.  You should be properly grounded and avoid
touching the gold contacts on the XMP/PCI controller.

Using the handles in a full PCI slot bay is recommended.  You
may need to remove the controller handles depending on the
size of you computer.  Make sure the XMP controller is fully
inserted and should fit securely in the PCI slot.
Do not force the controller.

After you install the XMP controller, close up the computer.
You are now ready to connect the cable from the XMP PCI
controller to the test stand.

1
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Now click the Trigger button and check that the Go button is
selected as the Start Condition and the Stop button is set as
the End Condition. Click OK.

Click the Go button. You will now see the selected traces being
graphed in the window. This data will continue on as the motor
spins.

At this point it may be hard to distinguish between the actual
position and command position traces.  Motion Scope allows
you to change the color (described below) of the traces and
‘Zoom In’ on an area of interest.

Click the Stop button.

Connecting the Test Stand to the
XMP Controller

First, connect the cable to the Axis 0-
1 port on the XMP via the smaller
VHDCI head on the cable supplied.

Make sure the power switch is in the
OFF position and plug in the test
stand power cord.

Next connect the SCSI head to the
test stand, (the test stand is 12 volt
single axis, sheet metal enclosed
with a brush DC servo motor with a
1000 count per revolution encoder)
and make sure the connector is firmly
inserted.

Switch the test stand power ON.  The
green Power On LED should brighten
on the MEI test stand.
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 MEI Test Stand
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Motion Scope

This section will illustrate some basic Motion Scope
features while executing a move via Motion Console.

With Motion Console open, launch Motion Scope  from the
Start Menu -> Program Files -> Motion Engineering ->
Motion Scope or from the Desktop.

After opening Motion
Scope, click File -> New
and you will see a new pane
appear.  Select Device (MPI)
Controller  0.  This will allow
data acquisition of Control-
ler 0 in Motion Console.
Click OK.

If the motor is not
currently spinning as
described in the last
section, following the
instructions to
generate a
trapezoidal move
repetitively before going any further.

The scope window will appear. Click the Traces button on

the top toolbar .  Select Ax 0 Cmd Pos from the left

column and click the Add button .  Then add the

Ax 0 Act Pos and Ax 0 TC.Velocity and Click OK. This will
effectively trace the Actual and Command position of the
move as
well as the
velocity
calculated
by the
trajectory
generator.

Adding New Hardware

Use this section if your system is Windows 2000,
98, or 95 ONLY.  If you are using Windows NT,
proceed to the next section, “Installing the MDK
Software”, as this section only applies to Plug and
Play operating systems.

 •  All screen shots for this section were taken in Windows
2000. If you are running Windows 95 or 98, your view may
look slightly different.

Windows 95, 98, and 2000 only:
After the controller card has been inserted into the PCI slot,
start up your system.

Plug and Play
will recognize
the new
hardware,
and launch
the Found
New Hard-
ware Wizard.

Select “Dis-
play a list of
the known
drivers for
this device so
that I can
choose a
specific
driver”.

1

2

3

1

2

3



920

Minimizing the Motion Console window while
motion is in progress will disrupt the motion.

    Preserve your changes by clicking the Save to Flash button
in the Motor Summary window.

If you power down your system, upon restarting
Motion Console certain preferences are lost if they
are not saved.  If you want to save all the
parameters and associations you just entered, go to
the MS Summary window, and click on the Save to
Flash button .  The Object
Pool contains categories by tab.  From here you can
add the Motion Summary, Filter, Axis and Motor
summary parameters by selecting items in the
Object Pool, then clicking the Add button.  Items will
be added to the Object List and are saved to flash
when the OK button is clicked.

The hardware device drivers are included on the CD that MEI
provides, so be sure that the ‘CD-ROM drive’ checkbox is
selected.

When a driver is located, verify that the meixmp.inf file inside
the /drivers/<OS Directory> was selected, then continue.

4
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Spinning the Motor

The next steps will execute a move and spin the test
stand motor.

Go to the MS Summary Window and under the Actions tab,
click the Zero Position button .

Then click the green Clear Fault button .  Be sure the
State under the General Status tab shows  .
Clicking on the Move Pos. 2 button 
will now run the commands you just entered. Clicking on the
Move Pos. 1 button  will move the axis
back to position 1.

You will notice the motor spinning on the test stand slowly for
several seconds.  If it is not moving, check to verify that the
power has been turned on, the amplifier has been enabled
and that the Axis Summary window is displaying CMD and
ACT position changes.  Also, check for any error messages
by clicking the error button, or by going to the View->
Library Errors menu option.

To repeat, click on the Enabled check box for the repeat mode
parameter in the Action Tab.

Now enter the following values in the Axis Summary window:
for Position 2, enter 1000: Velocity, enter 10000: Acceleration,
enter 50000 and for Deceleration enter 50000.  Click the 
button and then click Move Pos. 2  button ( MS Summary
Window).

The motor will now spin quickly back and forth. Leave the
motor spinning.

The next section will demonstrate data acquisition via Motion
Scope about the currently executing move.  You can stop
motion by clicking the Stop button, but resume the repeat
motion before moving on.

Complete the Found New Hardware Wizard by clicking Finish.6
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Installing the MDK Software

This section guides you through the software installation
process.  You must log on with administrative privileges,
since the setup process writes to the registry.

WARNING!
If you are upgrading from a previous MPI/XMP software
release, you must remove or archive all previous releases.  To
remove the previous MPI/XMP software release, click Start ->
Control Panel-> Add/Remove Programs.  Select the MPI/XMP
Development Toolkit entry and click the Add/Remove button.
Files that have been altered or added from previous
installations will not be removed.
The MPI/XMP software release can also be removed by running
the MDK Install Shield and choosing the Remove option.

Windows NT, 98, and 95 users:
The MDK installation process uses the Windows 2000 installer.
If this is not currently on your system, the MDK CD will
automatically install it on your system when launching the MDK
setup. The Install Wizard will reboot your system after these files
are installed.  Please shut down all programs before running the
Install Wizard for the first time.  If the Install Wizard does not re-
launch automatically, browse to the CD and click Setup.exe.

18

With MS 0 still highlighted in the Object Explorer window, click
on the Axis objects button  to open the Axis Summary
Window.  Under the Motion tab,
enter 1000 for Position 2, 1000
for Velocity, 5000 for Accelera-
tion, and 5000 for Deceleration.
The Relative Distance input field
should be left at 0.

You are now configured to run a simple trapezoidal move.  First,
we recommend arranging the windows on your desktop.  This is
a personal preference, but you want to try to see all the windows,
in particular, the MS Summary and Axis Summary windows.

4
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Insert the MDK CD. Launch the Setup.exe Install Shield Wizard
from the MDK CD in your CD-ROM drive. You will then be
prompted to select a setup language.

After a language is selected, a welcome screen will appear,
click Next to continue.

17

Controller Associations

During the following associations, leave the
summary windows open to keep them active.

In the Object Explorer window, make sure that MS 0 is still
highlighted. Click the Motion Supervisor object button 
from the Motion Control toolbar to open the MS Summary
Window.  In this window, verify that the Motion Type is set to
Trapezoidal under the General Config tab.  Go to the Actions

tab and click on the Clear Fault button .

With MS 0 still highlighted in the Object Explorer window, click
on the Filter object button  to open the Filter Summary
Window.  In this window under the General Config tab, make
sure the Algorithm is set to PID.  Click on the Coefficients tab

and select PID from the Algorithm drop-down menu .

Now enter:

800 for Proportional Gain (Kp)
8 for Integral Gain (Ki)
1,200 for Derivative Gain (Kd)
10,000 for Integrator Maximum at Rest (IMaxRest)

Go back  to the Object Explorer window with MS 0 still high-
lighted and click the Motor object button  to open the Motor
Summary Window.  Under the General Config tab in this
window, make sure the motor Type is set to Servo.  Verify that
the Amp Polarity is set to Inverted, and check the Amp
Enable checkbox to Enabled.  Ensure that the amplifier is
enabled by verifying that the Amp Enable LED on the test stand
is lit.
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At the install prompt, you may choose either Custom or Com-
plete as the installation type.  The Install Wizard will choose
C:\mei as the default destination directory.  You can choose
another directory by using the Custom installation, but MEI
recommends using the MEI default.

Custom lets you select the program features you want in-
stalled.

Setup will determine which files are needed and
create a Program Group on the Start Menu called
‘Motion Engineering’.  Setup will also install release
notes and late breaking documentation not covered
in this manual.

16

Motion Console
This section will show you how to configure Motion
console for a single axis move, in order to spin the
test stand motor. You will need to follow the next set
of steps to associate Motion Summary, Axis
Summary, Filter Summary and Motor Summary to
the Controller.

Launch Motion Console from the Start Menu -> Programs ->
Motion Engineering directory, or from the Desktop.

When the application starts up you may see Controller 0 with a

 sign next to it under the  submenu, in the
Object Explorer window.

If you do not see the Controller 0, click the Add Controller

button .  Click OK at the next prompt and you should see

Controller 0 with a  sign now appear in the main window.

This indicates the controller is seen.  If you do not see
Controller 0 with a ‘+’, check the controller’s error message
by clicking       or by going to the View-> Library Errors menu
option.  You may also need to perform the device driver
activation again, re-load the new firmware, and/or reinstall
the MEI software.  Also be sure the XMP card was properly
installed.

Open Controller 0 by clicking

on the .

Open the Motion Supervisors
by clicking on the .

Next, open the Axes Folder

again by clicking the .

Left Click on Axis 0 and drag it
onto MS 0. This associates
Axis 0 with Motion Supervisor
0. Click Yes at the prompt to
map Axis 0 to MS 0.
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The setup wizard prompts you that it is ready to install the
product.

Continue through the remainder of the installation windows by
clicking ‘Next’ when prompted.

15

When you reach the Setup Complete screen, click ‘Finish’ to
complete the installation.
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The setup wizard prompts you that it is ready to install the
product.

Continue through the remainder of the installation windows by
clicking ‘Next’ when prompted.

15

When you reach the Setup Complete screen, click ‘Finish’ to
complete the installation.
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At the install prompt, you may choose either Custom or Com-
plete as the installation type.  The Install Wizard will choose
C:\mei as the default destination directory.  You can choose
another directory by using the Custom installation, but MEI
recommends using the MEI default.

Custom lets you select the program features you want in-
stalled.

Setup will determine which files are needed and
create a Program Group on the Start Menu called
‘Motion Engineering’.  Setup will also install release
notes and late breaking documentation not covered
in this manual.
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Motion Console
This section will show you how to configure Motion
console for a single axis move, in order to spin the
test stand motor. You will need to follow the next set
of steps to associate Motion Summary, Axis
Summary, Filter Summary and Motor Summary to
the Controller.

Launch Motion Console from the Start Menu -> Programs ->
Motion Engineering directory, or from the Desktop.

When the application starts up you may see Controller 0 with a

 sign next to it under the  submenu, in the
Object Explorer window.

If you do not see the Controller 0, click the Add Controller

button .  Click OK at the next prompt and you should see

Controller 0 with a  sign now appear in the main window.

This indicates the controller is seen.  If you do not see
Controller 0 with a ‘+’, check the controller’s error message
by clicking       or by going to the View-> Library Errors menu
option.  You may also need to perform the device driver
activation again, re-load the new firmware, and/or reinstall
the MEI software.  Also be sure the XMP card was properly
installed.

Open Controller 0 by clicking

on the .

Open the Motion Supervisors
by clicking on the .

Next, open the Axes Folder

again by clicking the .

Left Click on Axis 0 and drag it
onto MS 0. This associates
Axis 0 with Motion Supervisor
0. Click Yes at the prompt to
map Axis 0 to MS 0.
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Insert the MDK CD. Launch the Setup.exe Install Shield Wizard
from the MDK CD in your CD-ROM drive. You will then be
prompted to select a setup language.

After a language is selected, a welcome screen will appear,
click Next to continue.

17

Controller Associations

During the following associations, leave the
summary windows open to keep them active.

In the Object Explorer window, make sure that MS 0 is still
highlighted. Click the Motion Supervisor object button 
from the Motion Control toolbar to open the MS Summary
Window.  In this window, verify that the Motion Type is set to
Trapezoidal under the General Config tab.  Go to the Actions

tab and click on the Clear Fault button .

With MS 0 still highlighted in the Object Explorer window, click
on the Filter object button  to open the Filter Summary
Window.  In this window under the General Config tab, make
sure the Algorithm is set to PID.  Click on the Coefficients tab

and select PID from the Algorithm drop-down menu .

Now enter:

800 for Proportional Gain (Kp)
8 for Integral Gain (Ki)
1,200 for Derivative Gain (Kd)
10,000 for Integrator Maximum at Rest (IMaxRest)

Go back  to the Object Explorer window with MS 0 still high-
lighted and click the Motor object button  to open the Motor
Summary Window.  Under the General Config tab in this
window, make sure the motor Type is set to Servo.  Verify that
the Amp Polarity is set to Inverted, and check the Amp
Enable checkbox to Enabled.  Ensure that the amplifier is
enabled by verifying that the Amp Enable LED on the test stand
is lit.
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Installing the MDK Software

This section guides you through the software installation
process.  You must log on with administrative privileges,
since the setup process writes to the registry.

WARNING!
If you are upgrading from a previous MPI/XMP software
release, you must remove or archive all previous releases.  To
remove the previous MPI/XMP software release, click Start ->
Control Panel-> Add/Remove Programs.  Select the MPI/XMP
Development Toolkit entry and click the Add/Remove button.
Files that have been altered or added from previous
installations will not be removed.
The MPI/XMP software release can also be removed by running
the MDK Install Shield and choosing the Remove option.

Windows NT, 98, and 95 users:
The MDK installation process uses the Windows 2000 installer.
If this is not currently on your system, the MDK CD will
automatically install it on your system when launching the MDK
setup. The Install Wizard will reboot your system after these files
are installed.  Please shut down all programs before running the
Install Wizard for the first time.  If the Install Wizard does not re-
launch automatically, browse to the CD and click Setup.exe.

18

With MS 0 still highlighted in the Object Explorer window, click
on the Axis objects button  to open the Axis Summary
Window.  Under the Motion tab,
enter 1000 for Position 2, 1000
for Velocity, 5000 for Accelera-
tion, and 5000 for Deceleration.
The Relative Distance input field
should be left at 0.

You are now configured to run a simple trapezoidal move.  First,
we recommend arranging the windows on your desktop.  This is
a personal preference, but you want to try to see all the windows,
in particular, the MS Summary and Axis Summary windows.

4
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Spinning the Motor

The next steps will execute a move and spin the test
stand motor.

Go to the MS Summary Window and under the Actions tab,
click the Zero Position button .

Then click the green Clear Fault button .  Be sure the
State under the General Status tab shows  .
Clicking on the Move Pos. 2 button 
will now run the commands you just entered. Clicking on the
Move Pos. 1 button  will move the axis
back to position 1.

You will notice the motor spinning on the test stand slowly for
several seconds.  If it is not moving, check to verify that the
power has been turned on, the amplifier has been enabled
and that the Axis Summary window is displaying CMD and
ACT position changes.  Also, check for any error messages
by clicking the error button, or by going to the View->
Library Errors menu option.

To repeat, click on the Enabled check box for the repeat mode
parameter in the Action Tab.

Now enter the following values in the Axis Summary window:
for Position 2, enter 1000: Velocity, enter 10000: Acceleration,
enter 50000 and for Deceleration enter 50000.  Click the 
button and then click Move Pos. 2  button ( MS Summary
Window).

The motor will now spin quickly back and forth. Leave the
motor spinning.

The next section will demonstrate data acquisition via Motion
Scope about the currently executing move.  You can stop
motion by clicking the Stop button, but resume the repeat
motion before moving on.

Complete the Found New Hardware Wizard by clicking Finish.6
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Minimizing the Motion Console window while
motion is in progress will disrupt the motion.

    Preserve your changes by clicking the Save to Flash button
in the Motor Summary window.

If you power down your system, upon restarting
Motion Console certain preferences are lost if they
are not saved.  If you want to save all the
parameters and associations you just entered, go to
the MS Summary window, and click on the Save to
Flash button .  The Object
Pool contains categories by tab.  From here you can
add the Motion Summary, Filter, Axis and Motor
summary parameters by selecting items in the
Object Pool, then clicking the Add button.  Items will
be added to the Object List and are saved to flash
when the OK button is clicked.

The hardware device drivers are included on the CD that MEI
provides, so be sure that the ‘CD-ROM drive’ checkbox is
selected.

When a driver is located, verify that the meixmp.inf file inside
the /drivers/<OS Directory> was selected, then continue.
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Motion Scope

This section will illustrate some basic Motion Scope
features while executing a move via Motion Console.

With Motion Console open, launch Motion Scope  from the
Start Menu -> Program Files -> Motion Engineering ->
Motion Scope or from the Desktop.

After opening Motion
Scope, click File -> New
and you will see a new pane
appear.  Select Device (MPI)
Controller  0.  This will allow
data acquisition of Control-
ler 0 in Motion Console.
Click OK.

If the motor is not
currently spinning as
described in the last
section, following the
instructions to
generate a
trapezoidal move
repetitively before going any further.

The scope window will appear. Click the Traces button on

the top toolbar .  Select Ax 0 Cmd Pos from the left

column and click the Add button .  Then add the

Ax 0 Act Pos and Ax 0 TC.Velocity and Click OK. This will
effectively trace the Actual and Command position of the
move as
well as the
velocity
calculated
by the
trajectory
generator.

Adding New Hardware

Use this section if your system is Windows 2000,
98, or 95 ONLY.  If you are using Windows NT,
proceed to the next section, “Installing the MDK
Software”, as this section only applies to Plug and
Play operating systems.

 •  All screen shots for this section were taken in Windows
2000. If you are running Windows 95 or 98, your view may
look slightly different.

Windows 95, 98, and 2000 only:
After the controller card has been inserted into the PCI slot,
start up your system.

Plug and Play
will recognize
the new
hardware,
and launch
the Found
New Hard-
ware Wizard.

Select “Dis-
play a list of
the known
drivers for
this device so
that I can
choose a
specific
driver”.
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Now click the Trigger button and check that the Go button is
selected as the Start Condition and the Stop button is set as
the End Condition. Click OK.

Click the Go button. You will now see the selected traces being
graphed in the window. This data will continue on as the motor
spins.

At this point it may be hard to distinguish between the actual
position and command position traces.  Motion Scope allows
you to change the color (described below) of the traces and
‘Zoom In’ on an area of interest.

Click the Stop button.

Connecting the Test Stand to the
XMP Controller

First, connect the cable to the Axis 0-
1 port on the XMP via the smaller
VHDCI head on the cable supplied.

Make sure the power switch is in the
OFF position and plug in the test
stand power cord.

Next connect the SCSI head to the
test stand, (the test stand is 12 volt
single axis, sheet metal enclosed
with a brush DC servo motor with a
1000 count per revolution encoder)
and make sure the connector is firmly
inserted.

Switch the test stand power ON.  The
green Power On LED should brighten
on the MEI test stand.
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Click and drag a selection
of the display like the one
shown.

Click the ‘Zoom In’ button

.  This will give a

finer resolution of the data.

To better distinguish between
separate traces, select Ax 0 Cmd
Pos from the trace field (you can
also select the trace by right
clicking on the trace directly) and
select Trace -> Color from the menu.   You are now pre-
sented with a color palette to choose a variety of preset
colors along with the option to customize colors to assign to
any trace.

Choose a color and click OK.

Installing the XMP Controller

The XMP/PCI controller fits into a full-sized PCI
slot in your computer.  Because PC configurations
vary, we recommend you refer to the expansion
card installation instructions that came with your
computer.  If you do not feel comfortable
performing the hardware installation, consult a
qualified technician.  Please refer to the Safety
Precautions located at the beginning of this
manual.

•  MEI assumes no liability for any damage caused either
directly or indirectly  by improper installation of compo-
nents.

•  Make sure power is
OFF during the installa-
tion.

Shut down your computer
and follow the manufactur-
ers instruction for opening
the computer and install-
ing hardware.  You should be properly grounded and avoid
touching the gold contacts on the XMP/PCI controller.

Using the handles in a full PCI slot bay is recommended.  You
may need to remove the controller handles depending on the
size of you computer.  Make sure the XMP controller is fully
inserted and should fit securely in the PCI slot.
Do not force the controller.

After you install the XMP controller, close up the computer.
You are now ready to connect the cable from the XMP PCI
controller to the test stand.
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Parts List
MEI supplied components to get you started.

XMP Series Controller

Connector Cable*

Single Axis MEI Test Stand*
(power cable included)

*  Available with the Motion Developer’s Kit.  Please
contact Motion Engineering for more information.

Motion Developers Kit CD*

24

When selecting a trace, by default it will turn white
indicating selection.  The selected trace will remain
white until you deselect or click anywhere on the
scope background.  You should notice the trace
selected for command position is now the color you
chose.  To return to the normal view click the ‘Zoom
Out’ button.

Go back to Motion Console and stop the motion by clicking on
the Stop button in the MS Summary window under the Actions
tab.

Zero the register by clicking the   button and clear any
faults by clicking the clear fault button  .  This will ready
the controller for carrying out the quickstart1.c program cov-
ered in the next section.
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Overview
XMP PCI and the Motion Developer Kit (MDK)

This guide will take you through installing the Motion Developer

Kit (MDK) software and the XMP motion controller.  You will use

Motion Console to run a simple trapezoidal move with the test

stand motor and Motion Scope to gather information about the

associated motion.  This guide lets  you sample some of the

powerful tuning tools MEI offers to get you up and running fast.

This guide also shows how to execute a C-program using

Microsoft Visual C/C++ to introduce users to executing files

developed from C-code.  If you are not running MSVC v.4 or

higher, this portion of the guide will not apply.  However the

MDK supports C-code written on many platforms to perform

motion tasks.

25

Microsoft Visual C/C++
This section is an overview of running an
executable C-program via Microsoft Visual C/C++.
If you are not currently running MS Visual C/C++,
this section will not apply.  However, the XMP can
be controlled by a C-program written on many
different  platforms; this section covers MS Visual
C/C++ only.

Open Visual C/C++ Version 4 or higher.

Go to File -> Open Workspace.  Browse for app.mak. Usually
in    C-> MEI -> XMP ->
APP -> (OSDirectory)
-> MSVC.

The file type should be
set to display Makefile
[.mak] and upon doing
so the app.mak file
appears.  Open
app.mak and click Yes
to convert to the
version of visual C/
C++ you are running.

At this screen click OK, or press Enter if the button is off the
screen.
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Change to File View  and select quickStart1 files.

Right click on the quickStart1 files and ‘Set as Active Project”:
this should set the quickStart1 files in bold.

Click on quickStart1.c in the ‘Source Files’ sub directory.

Go to the Build menu and select Build quickStart1.exe.

Make sure that there are no errors or warnings in the dialog
box.
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Safety Precautions
Mechanical Hazards
The following mechanical precautions should always be observed, especially when
operating large, powerful components:
Crush-Collision Danger to Personnel— Even small mechanical components can exert
sufficient force to crush or injure you! Before powering your motion control system, verify
that personnel, including their hands, fingers and feet are clear of the movement zone. If
you have not already done so, define the movement zone, then employ barriers and/or
clearly marked boundary lines so that personnel are excluded from the zone. Before
powering motion control components, verify that all personnel remain outside the
movement zone.
Crush-Collision Hazard to Equipment— The same precautions applied to personnel
should be observed for equipment. Components can be damaged or destroyed due to
collision with other components or fixed hardware.
Component Hazards— Motion control may be applied to components which them-
selves present hazards. These include welders, saws, lasers, presses, cutters, etc. Be
aware that the introduction of movement to a component extends the reach and range
of that component’s hazards. In addition, any object can be made dangerous if suddenly
jarred loose or pitched due to sudden, wild movements. When testing new applications,
it is recommended that you begin at very low speeds, then slowly increase to the design
speed.

Electrical Hazards
Electrocution Hazard— Some motion control systems utilize high voltages and currents
which present hazards to personnel. During installation and servicing of components:
Power off all electrical components and accessories connected to your motion control
system.
Unplug electrical devices from their source of power. Safe-lock all power plugs to
prevent them from being plugged in during servicing.
Allow sufficient time for components using capacitors to discharge fully before making
connections.
Do not repower any components until installation is complete and personnel are clear of
component spaces.
ESD— Due to the use of sensitive microelectronics, all XMP boards are subject to
damage due to electrostatic discharge (ESD). When handling XMP components, users
are advised to observe basic ESD precautions, including the use of grounding straps
and grounding mats. Removed XMP components should always be stored in protective
ESD bags and/or cases.
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This guide is intended to be an introductory
manual covering MEI’s robust software and
tuning utilites.  For full documentation on all of
MEI’s products and capabilites please visit us
on the web at www.motioneng.com or email
info@motioneng.com.

Click the execute button and the program will now be
carried out.  You can stop the motion anytime by hitting any
key.

Open Motion Scope and here again you can view certain
parameters by selecting the Trace button and adding those
parameters you want to graph.�
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